You are here

Python 2.5 en Debian Lenny

Hace poco hablábamos con Warwolf sobre la instalación de Python, y como usar en Etch por defecto el intérprete de Python 2.5 (cuando en Debian Etch es el 2.4)

La tarea es muy sencilla, de hecho basta con tan solo cambiar donde apunta el enlace simbólico y listos. De todos modos cambiar el intérprete por defecto puede acarrearnos problemas ya que las aplicaciones Python que instalemos en Debian Etch han sido probadas para que funcionen correctamente usando Python 2.4

De todos modos, ya podemos avanzar (al estar Debian Lenny congelada) que la nueva release traerá el intérprete por defecto en su versión 2.5, esto es lo que se puede apreciar observando los release goals (objetivos de la release) de Lenny.

Obviamente para conseguir completo soporte para Python 2.5 todos los paquetes de la distribución (que no son pocos) deben soportar el intérprete Python 2.5 por defecto, tal y como se detalla en los bugs etiquetados goal-python2.5: para ello se han tenido que resolver 2 bugs clasificados como normales, 46 importantes, 28 serios o que violan la política Debian o hacen que los paquetes no encajen en la release y aún quedan 2 importantes (uno con un parche disponible y otro sin clasificar). Desde luego un gran trabajo por parte del equipo de Debian.

Una interesante mejora para aquellos desarrolladores que trabajan con Python, de la mano de Lenny, que tal vez pronto estará en muchos servidores en producción.

Debian: 
Qué te parece: