You are here

Editor de dialplan gráfico Dialogpalette

DialogPalette nos permite diseñar complejas aplicaciones para Asterisk de manera visual mientras va generando el dialplan dinámicamente. Vendría a ser una perfecta alternativa libre (con licencia GPL) a la aplicación comercial Visual Dialplan.

Esta herramienta esta desarrollada usando C++, Python y las librerías QT3 para la interfaz de usuario, actualmente está en un estado beta 4 y corre sobre GNU/Linux.

El aspecto nos resultará muy familiar si estamos acostumbrados a trabajar con IDEs para desarrollo y generadores visuales de código, además tenemos la posibilidad de simular nuestro diseño del dialplan:

DialogPalette Dialplan

Permite manejar las propiedades y eventos de varios elementos, audio, call management, manipulación de variables, voicemail:

DialogPalette Dialplan Objects

Mientras diseñamos nuestro dialplan de va generando de forma dinámica y lo podemos ver en la pestaña código:

DialogPalette Code

La única pega que le he encontado es que según comentan en el sitio web el desarrollo de la herramienta DialogPalette esta actualmente suspendido. Los módulos text-to-speech desarrollados originalmente como parte del proyecto (asterisk-flite y asterisk-espeak) están todavía en activo desarrollo. En la página de descarga nos ofrecen más información.

Asterisk: 
GNU/Linux: 
Qué te parece: 

Comments

Hola, saludos desde Argentina! Pudiste instalar u compilar este programa?? podrias orientarme como ya que lo trato de compilar en un debian Lenny o Ubuntu 9.10 pero al parecer no es compatible la version de phyton y no funca

Gracias!!

Hola Julio,

lo compilé sí. No recuerdo que tuviera ningún problema, aunque tampoco recuerdo que versión de Python usé y si lo compilé en Lenny o en Etch. Creo que en cualquier caso no te queda otra que cambiar la versión de Python. Triste

Saludos.

Se que el tema, está bastante pasado de tiempo...pero no puedo instalar este paqute, actualmente tengo la versión de python 2.7, pero me da el siguiente error:

Project MESSAGE: Python >= 2.3 could not be found on your system, please install it.
Project MESSAGE: If you have Python installed, please edit the file src/src.pro to point to it
Project ERROR: Could not find Python.
make: *** [src//Makefile] Error 2
cd src/ && /usr/bin/qmake /home/pdguinazu/Escritorio/dialogpalette-0.8.3/src/src.pro -o Makefile
Project MESSAGE: Python >= 2.3 could not be found on your system, please install it.
Project MESSAGE: If you have Python installed, please edit the file src/src.pro to point to it
Project ERROR: Could not find Python.
make: *** [src//Makefile] Error 2

y en mi carpeta /usr/includes me figura lo siguiente:

$ cd python2.
python2.6/ python2.6_d/ python2.7/ python2.7_d/

Alguien puede darme una mano?????

Desde ya se los agradezco!!